跳转到主内容
websoft网络软件专家 - 深耕网络技术,打造实用软件!

Linux环境下安装MySQL数据库

目录

1.概述

2.前期准备

2.1下载mysql二进制安装包

2.2导入mysql二进制安装包

3.mysql部署

4.修改mysql密码

5.配置mysql阿里云安全组策略

1.概述

对于mysql二进制安装,优点是可以安装到任何路径下,灵活性好,一台服务器可以安装多个mysql。缺点是已经编译过,性能不如源码编译得好,不能灵活定制编译参数。如果用户即不想安装最简单却不够灵活的RPM包,又不想安装复杂费时的源码包,那么已编译好的二进制包将是最好的选择,下面让我们来介绍如何在linux系统下安装mysql服务端。

2.前期准备

2.1下载mysql二进制安装包

mysql官网:

https://dev.mysql.com/downloads/mysql/

因为我下载的是mysql-8.0.23-linux-glibc2.12-x86_64.tar版本,如果有最新版本,则下载最新版本就好了。

2.2导入mysql二进制安装包

通过Xftp工具把安装包传输到linux系统package目录去:

3.mysql部署

解压mysql安装包--切换到安装目录cd /app--解压xz压缩文件tar -xvf /app/package/mysql-8.0.23-linux-glibc2.12-x86_64.tar.xz修改mysql文件夹名称--把mysql-8.0.23-linux-glibc2.12-x86_64修改为mysql文件夹名称mv /app/mysql-8.0.23-linux-glibc2.12-x86_64 /app/mysql创建data目录--在mysql根目录下创建data目录,用于存放数据mkdir /app/mysql/data创建mysql用户组和mysql用户--创建mysql用户组和mysql用户groupadd mysql useradd -g mysql mysql修改mysql目录权限--修改mysql目录权限chown -R mysql.mysql /app/mysql/初始化数据库--先切换到mysql安装目录cd /app/mysql--初始化数据库bin/mysqld --initialize --user=mysql --basedir=/app/mysql --datadir=/app/mysql/data

配置mysql--先切换到mysql.support-files目录cd /app/mysql/support-files--在mysql/support-files创建文件my-default.cnf touch my-default.cnf--复制配置文件到/etc/my.cnf cp -a ./my-default.cnf /etc/my.cnf--编辑my.cnf vim /etc/my.cnfmy.cnf输入如下配置内容:[client]port=3306 socket=/tmp/mysql.sock

[mysqld]port=3306 user=mysql socket=/tmp/mysql.sock basedir=/app/mysql datadir=/app/mysql/data配置环境变量--编辑profile文件vim /etc/profile--配置mysql环境变量PATH=/data/mysql/bin:/data/mysql/lib:$PATH export PATH--使mysql环境变量生效source /etc/profile--看环境变量是否生效echo $PATH启动mysqlcd /app/mysql/bin systemctl start mysqld or service mysql start启动mysql时候可能会遇到如下错误:Failed to start mysqld.service: Unit not found.

or Starting MySQL.Logging to '/app/mysql/data/dengwu.err'.

... ERROR! The server quit without updating PID file (/app/mysql/data/dengwu.pid).

解决方法如下:--需要安装mariadb-server yum install -y mariadb-server--然后启动mariadb服务systemctl start mariadb.service--需要的可以添加mariadb服务开机启动systemctl enable mariadb.serviceJob for mariadb.service failed because the control process exited with error code. See "systemctl status mariadb.service" and "journalctl -xe" for details.

解决方法如下:chown -R mysql.mysql /app/mysql/Starting MySQL... ERROR! The server quit without updating PID file (/app/mysql/data/dengwu.pid).

解决方法如下:--查看mysql进程ps -ef|grep mysqld--杀死mysql进程kill -9 mysql进程ID

然后重新启动下mysql:

4.修改mysql密码

root用户第一次登录mysql,因为初始密码我们并不知道,一般情况下我们都会重新设置一个新的密码,具体操作如下:--编辑my.cnf vim /etc/my.cnf

输入如下命令行:

default_authentication_plugin=mysql_native_password

如果忘记了密码再加上:

--跳过密码验证(等设置了密码就去掉) skip-grant-tables

然后登录mysql:

--登录mysql mysql -u root -p然后输入命令查看mysql用户组:--查看mysql用户表select user,host,authentication_string from mysql.user;

看看root用户没有开启远程连接权限,如果没有则执行如下命令:--修改root用户可以远程连接update mysql.user set host='%' where user='root';开启远程连接权限后,再来修改root用户密码:--如果host是localhost则@字符后面是localhost,反之则是%,以host结果为准--修改加密规则alter user 'root'@'%' identified by 'qwer1234' password expire never;--更新一下用户的密码alter user 'root'@'%' identified with mysql_native_password by 'qwer1234';--刷新权限flush privileges;--修改root用户密码alter user 'root'@'%' identified by 'qwer1234';

如果防火墙开启了,则需要加入允许mysql端口访问权限,具体命令如下:--允许访问firewall-cmd --permanent --zone=public --add-port=3306/tcp--重新加载firewall-cmd --reload--查看是否开通访问权限firewall-cmd --permanent --zone=public --query-port=3306/tcp

然后重新启动mysql:

--重新启动mysql service mysql restart;

5.配置mysql阿里云安全组策略

登录阿里云->安全组规则->访问规则->入方向->手动添加如下策略:

使用Navicat连接成功:

到此这篇关于Linux环境下安装MySQL数据库的文章就介绍到这了。希望对大家的学习有所帮助,也希望大家多多支持脚本之家。

您可能感兴趣的文章:Linux环境下安装mysql5.7.36数据库教程linux环境下安装mysql8.0过程介绍Linux7.6二进制安装Mysql8.0.27详细操作步骤Linux下安装MySQL教程Linux下MySQL多实例部署及安装指南Linux下mysql 8.0.25 安装配置方法图文教程mysql8.0.23 linux(centos7)安装完整超详细教程linux环境下安装mysql数据库的详细教程Linux下安装mysql-8.0.20的教程详解Linux系统MySQL8.0.19快速安装配置教程图解linux centos7安装mysql8的教程

相关文章