跳转到主内容
websoft网络软件专家 - 深耕网络技术,打造实用软件!

启动sshd时,报“Could not load host key”错_PHP教程

Android开发教程与笔记pdf版 Android文件存取与数据库编程知识,文件操作主要是读文件、写文件、读取静态文件等,同时还介绍了创建添加文件内容并保存,打开文件并显示内容;数据库编程方面主要介绍了SQLite数据库的使用、包括创建、删除、打开数据库、非查询SQL操作指令、查询SQL指令-游标Cursors等知识。 下载 启动sshd时,报“could not load host key”错 现象:启动sshd服务时,虽看似服务启动成功,但客户端并不能连接上sshd服务器端。 如下:
  1. [root@aefe8007a17d ~]# /usr/sbin/sshd
  2. could not load host key: /etc/ssh/ssh_host_rsa_key
  3. could not load host key: /etc/ssh/ssh_host_ecdsa_key
  4. could not load host key: /etc/ssh/ssh_host_ed25519_key
原因: 1. 从提示信息看是sshd守护进程不能加载主机密钥文件,因为找不到这些密钥文件(配置文件/etc/ssh/sshd_config中已定义密钥文件名与路径); 2. 一般openssh服务正常安装后,主机会自动生成相应的主机密钥文件,但这里因未知原因并没有完成这一步动作,导致无法远程ssh连接。 检查密钥文件是否存在(还有一种现象为:密钥文件存在,但文件大小为0):
  1. [root@aefe8007a17d ~]# ll /etc/ssh/
  2. total 252
  3. -rw-r--r-- 1 root root 242153 mar 21 22:18 moduli
  4. -rw-r--r-- 1 root root 2208 mar 21 22:18 ssh_config
  5. -rw------- 1 root root 4361 mar 21 22:18 sshd_config
重新生成主机密钥文件: 1. 生成rsa_key (-t表示生成的密钥所使用的加密类型;-f项后接要生成的密钥文件名);
  1. [root@aefe8007a17d ~]# ssh-keygen -t rsa -f /etc/ssh/ssh_host_rsa_key
  2. generating public/private rsa key pair.
  3. enter passphrase (empty for no passphrase):
  4. enter same passphrase again:
  5. your identification has been saved in /etc/ssh/ssh_host_rsa_key.
  6. your public key has been saved in /etc/ssh/ssh_host_rsa_key.pub.
  7. the key fingerprint is:
  8. 5e:2d:19:51:b1:e3:e0:60:65:53:e4:14:f8:d8:38:af root@aefe8007a17d
  9. the key's randomart image is:
  10. +--[ rsa 2048]----+
  11. | ==bo |
  12. | o.= . |
  13. | o o=+ |
  14. | . o+*o. |
  15. | s =oo |
  16. | . . .. |
  17. | . . |
  18. | e |
  19. | |
  20. +-----------------+
  21. [root@aefe8007a17d ~]# ssh-keygen -t ecdsa -f /etc/ssh/ssh_host_ecdsa_key

2. 生成ecdsa_key;
  1. [root@aefe8007a17d ~]# ssh-keygen -t ecdsa -f /etc/ssh/ssh_host_ecdsa_key
3. 生成ed25519_key。
  1. [root@aefe8007a17d ~]# ssh-keygen -t ed25519 -f /etc/ssh/ssh_host_ed25519_key
再次检查密钥文件是否存在且合规,可以看到已生成相应主机密钥文件(实际上主机密钥文件为私钥,.pub文件为公钥):
  1. [root@aefe8007a17d ~]# ll /etc/ssh/
  2. total 276
  3. -rw-r--r-- 1 root root 242153 mar 21 22:18 moduli
  4. -rw-r--r-- 1 root root 2208 mar 21 22:18 ssh_config
  5. -rw------- 1 root root 227 may 22 16:48 ssh_host_ecdsa_key
  6. -rw-r--r-- 1 root root 179 may 22 16:48 ssh_host_ecdsa_key.pub
  7. -rw------- 1 root root 411 may 22 16:48 ssh_host_ed25519_key
  8. -rw-r--r-- 1 root root 99 may 22 16:48 ssh_host_ed25519_key.pub
  9. -rw------- 1 root root 1679 may 22 16:48 ssh_host_rsa_key
  10. -rw-r--r-- 1 root root 399 may 22 16:48 ssh_host_rsa_key.pub
  11. -rw------- 1 root root 4361 mar 21 22:18 sshd_config
此时客户端可ssh连接上sshd服务器端:
  1. [root@localhost ~]# ssh 172.17.0.2
  2. the authenticity of host '172.17.0.2 (172.17.0.2)'can't be established.
    ecdsa key fingerprint is 37:2a:69:46:c4:bd:92:b2:43:b4:cc:42:41:8e:12:2e.
    are you sure you want to continue connecting (yes/no)?
http://www.bkjia.com/PHPjc/1128994.html www.bkjia.com true http://www.bkjia.com/PHPjc/1128994.html TechArticle 启动sshd时,报“Could not load host key”错 现象:启动sshd服务时,虽看似服务启动成功,但客户端并不能连接上sshd服务器端。 如下: [root@a...

相关文章